The package jedit needs to be reinstalled, but I can’t find an archive for it

August 10th, 2006 by Marius Hanganu in Tools

I tried installing the .deb package for jedit. Big mistake :-). Not only that Ubuntu refused installing it, but it also brought my synaptic into an incosistent state: every time I started synaptic I was getting this error:

The package jedit needs to be reinstalled, but I can't find an archive for it

and then no package was displayed. One of the reasons I like Linux (Ubuntu) over Windows is apt and the synaptic interface. Imagine my desolation.

I tried various “apt-get remove jedit”, clean, autoclean options. No luck. Neither the guys on Ubuntu mailing list could help me out here. Tried removing it using dpkg and I got

dpkg: error processing jedit (--purge):

Package is in a very bad inconsistent state - you should reinstall it before

attempting a removal.

Errors were encountered while processing: jedit

But I finally got it working. This command forced the removal of my incosistent jedit package:

dpkg --remove --force-remove-reinstreq jedit

 

Update: after I managed to fix it and post this entry, I was finally pointed on ubuntu users mailing list to http://ubuntuforums.org/showthread.php?t=232849&highlight=jedit. Phew! lots of replies before the author figured the answer for himself.

DZoneGoogle ReaderYahoo MessengerRedditEmailDelicious

You might also like

Create a Solr filter that replaces diacritics Some languages (like Romanian) have special characters (diacritics, often called accent marks). It's...
Avoiding SQL joins with java enums Lets say you have a Coffee object and 3 sizes for coffee (small, medium and large).You can create a Coffee...
Solution to a problem with VMware Server 1.0.1 on Linux kernel 2.6.19-1.2288.fc5 – ‘CHECKSUM_HW’ undeclared (first use in this function) Solution to the following problem with VMware Server 1.0.1 on Linux kernel 2.6.19-1.2288.fc5 : 'CHECKSUM_HW'...
Intellij Idea versus Eclipse – part I >> 10 reasons why Idea is better In this part I'm focusing on advantages of Idea over Eclipse....
.

22 Responses

  1. Mason Says:

    Just wanted to say thank for the solution. Just a quick note, if you copy & paste code the hyphens join together, causing the command line fail.
    Just make use there are two hyphens, ie. ‘ – – ‘ before force and remove.

  2. Lucas ALves Says:

    Tks for tips man!
    I haved this problem with opera.

    Very tks

  3. Kalyan Says:

    Thanks a lot dude.

  4. Nick Says:

    Thanks man! I had this same problem.

    You’re a life saver.

  5. Rickard Says:

    Thanks a lot.

  6. kannu Says:

    thanx a tonn mann……was stuck wid it for hours……. :-)

  7. Cameron Says:

    THANX!! This has been a real pain.

  8. s3rg Says:

    Tnx man, solved time for me.

  9. chas Says:

    I had the same problem with the drivers of a Brother multifunction.

    I could fix the problem with ‘dpkg –remove –force-remove-reinstreq mfc9070lpr’. But first, had to remove all the archives (scripts) whose name began with mfc9070 in the directory /var/lib/dpkg/info/ .

    I expect it will be useful.

  10. chapman Says:

    chas, thanks, that was a lifesaver.

  11. maarten Says:

    Thanks chas, I had the same problem with maya (awcommon package), and I didn’t manage to fix my problem (which I created myself), but canceling the files in the /var/lib/dpkg/info/ directory solved my problem!

  12. P Says:

    Thanks you saved my evening : )

    And I’ll remember to search first before playing around myself

  13. j.miller565 Says:

    Thank you so much.

  14. Phil Says:

    Thanks a heap. A solution at last!

  15. ragingmon Says:

    @maarten

    can you help me on removing this awcommon. I’ve tried everthing bu no luck at all. I really don’t know any way around this.. please help…

  16. ragingmon Says:

    ohhh my!!! I just removed the awcommon…
    sorry for the double post,stupid me..
    I read the post of chas and that’s it!!
    tnx to all!!!

  17. Posterus Says:

    thanks man i had the exact same problem with opera and now it’s working fine, i wasnt able to update anything b4 i did this

  18. Removing awcommon package « ragingmon Says:

    […] The package jedit needs to be reinstalled, but I can’t find an archive for it […]

  19. carlos Says:

    thx a bunch Marius, Mason, and chas!!

  20. Brian Says:

    Yes Chas, thanks for that…

  21. Buy Online Says:

    Good Article

  22. mb Says:

    Thankss so much . saved my night

Leave a Comment

Please note: Comment moderation is enabled and may delay your comment. There is no need to resubmit your comment.